Is your practice ready to run Simplifeye? Check for your system requirements below:

Devices 

  • Apple Watch Series 1 or newer, running WatchOS 3 and newer.
  • iPhone 5S or newer, running iOS 10 and newer.
  • Android devices running Android 5.0 and newer.
  • Android Wear devices running Android Wear 2.0 and newer.
  • A desktop computer with an Intel® Core™ 2 Duo processor (2.4 GHz
    per core) or better, with 4GB of RAM or better.

Browsers

  • Any of the following web browsers and newer versions: Google Chrome 47 (preferred browser), Internet Explorer 11, Firefox 43, Safari 9.

Practice Management Software (Simplifeye Flow)

  • OMSVision 13.1 and newer with SQL Anywhere 12 or 16.
  • Dentrix G5.2 and newer.
  • Eaglesoft 17 and newer.
  • MicroMD 11 and newer.

Operating System

  • Windows Server 2016 Standard/Datacenter
  • Windows Server 2012 R1/R2 Standard/ Datacenter
  • Windows Server 2008 R1/R2 Standard/ Enterprise/Datacenter
  • Windows 10 Pro/Enterprise
  • Windows 8/8.1 Pro/Enterprise
  • Windows 7 Pro/Enterprise
  • Windows Vista

If devices are needed, iPhones, Apple Watches and Android Wear devices are available as part of your Simplifeye subscription. If you have a system setup that is not listed above, please contact Simplifeye Support.

Did this answer your question?